]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/sword/sword_1.5.8.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / sword / sword_1.5.8.bb
1 DESCRIPTION = "The SWORD Project is an open source, cross-platform \
2 (Linux, Windows, Solaris, MacOSX etc.) API and library for \
3 Bible software with a constantly growing list of front-ends \
4 (GUI, textmode, web-based, etc.) and a library of over 200 text modules"
5 SECTION = "libs"
6 PRIORITY = "optional"
7 LICENSE = "GPL"
8
9 SRC_URI = "http://www.crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
10
11 inherit autotools 
12
13 EXTRA_OECONF = "--without-clucene --without-curl"
14
15 do_stage() {
16         oe_libinstall -so -C lib libsword ${STAGING_LIBDIR}
17
18         install -d ${STAGING_INCDIR}/sword/
19         for f in include/*.h
20         do
21                 install -m 0644 $f ${STAGING_INCDIR}/sword/
22         done
23
24 }