]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/syslinux/syslinux-native_2.11.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / syslinux / syslinux-native_2.11.bb
1 # syslinux-native OE build file
2 # Copyright (C) 2004, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 DESCRIPTION="A multi-purpose linux bootloader"
6 HOMEPAGE="http://syslinux.zytor.com/"
7 LICENSE="GPL"
8
9 SRC_URI="http://www.kernel.org/pub/linux/utils/boot/syslinux/Old/syslinux-${PV}.tar.bz2"
10
11 S="${WORKDIR}/syslinux-${PV}"
12
13 # If you really want to run syslinux, you need mtools.  We just want the 
14 # ldlinux.* stuff for now, so skip mtools-native
15
16 DEPENDS="nasm-native"
17
18 inherit native
19
20 do_compile() {
21         oe_runmake syslinux
22 }
23
24 do_stage() {
25         install -d ${STAGING_BINDIR}
26         install -m 755 ${S}/syslinux ${STAGING_BINDIR}
27
28         # When building media, the syslinux binary isn't nearly as useful
29         # as the DOS data files, so we copy those into a special location
30         # for usage during a image build stage
31
32         install -d ${STAGING_DATADIR}/syslinux
33         install -m 644 ${S}/ldlinux.sys ${STAGING_DATADIR}/syslinux/ldlinux.sys
34         install -m 644 ${S}/ldlinux.bss ${STAGING_DATADIR}/syslinux/ldlinux.bss
35 }