]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/taglib/taglibc_1.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / taglib / taglibc_1.4.bb
1 DESCRIPTION = "TagLib is a library for reading and editing the meta-data \
2 of several popular audio formats. Currently it supports both ID3v1 and ID3v2 \
3 for MP3 files, Ogg Vorbis comments and ID3 tags and Vorbis comments in FLAC files"
4 SECTION = "libs"
5 HOMEPAGE = "http://developer.kde.org/~wheeler/taglib.html"
6 DEPENDS = "taglib"
7 LICENSE = "LGPL"
8
9 SRC_URI = "http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz"
10 S = "${WORKDIR}/taglib-${PV}"
11
12 inherit autotools qmake-base pkgconfig binconfig
13
14 do_configure() {
15         echo running oe_runconf to get pkgconfig and binconfig files created          
16         oe_runconf
17         cd ${S}/bindings/c && rm -f Makefile* && qmake -project -o tag_c.pro -t lib && \
18         qmake -spec ${QMAKESPEC} -after CONFIG=console INCLUDEPATH+=${STAGING_INCDIR}/taglib LIBS+=-ltag
19 }
20
21 do_compile() {
22         oe_runmake -C bindings/c
23 }
24
25 do_stage_append() {
26         install -d ${STAGING_INCDIR}/taglib
27         install -m 0644 bindings/c/tag_c.h ${STAGING_INCDIR}
28         oe_libinstall -so -C bindings/c libtag_c ${STAGING_LIBDIR}
29 }
30
31 do_install() {
32     oe_libinstall -so -C bindings/c libtag_c ${D}${libdir}
33 }