]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/tar/tar_1.13.93.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / tar / tar_1.13.93.bb
1 SECTION = "base"
2 DESCRIPTION = "GNU tar saves many files together into a single tape \
3 or disk archive, and can restore individual files from the archive."
4 LICENSE = "GPL"
5 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
6 PR = "r1"
7
8 SRC_URI = "ftp://alpha.gnu.org/gnu/tar/tar-${PV}.tar.gz \
9            file://configure.patch;patch=1 \
10            file://m4.patch;patch=1"
11
12 inherit autotools
13
14 do_install () {
15         autotools_do_install
16         install -d ${D}${base_bindir}
17         mv ${D}${bindir}/tar ${D}${base_bindir}/tar.${PN}
18         mv ${D}${libexecdir}/rmt ${D}${libexecdir}/rmt.${PN}
19 }
20
21 pkg_postinst_${PN} () {
22         update-alternatives --install ${base_bindir}/tar tar tar.${PN} 100
23         update-alternatives --install ${libexecdir}/rmt rmt rmt.${PN} 100
24 }
25
26 pkg_prerm_${PN} () {
27         update-alternatives --remove tar tar.${PN}
28         update-alternatives --remove rmt rmt.${PN}
29 }