]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/tetex/tetex_3.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / tetex / tetex_3.0.bb
1 DESCRIPTION = "teTeX is a complete TeX distribution for UNIX compatible systems"
2 LICENSE = "GPL"
3 SECTION = "console/utils"
4 DEPENDS = "tetex-native flex gd ncurses libpng t1lib x11 xau xext xt zlib"
5 TETEX_BUILDSYSTEM_TAMER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
6 PR = "r2"
7
8 SRC_URI = "ftp://dante.ctan.org/tex-archive/systems/unix/teTeX/current/distrib/tetex-src-${PV}.tar.gz \
9            file://configure.patch;patch=1"
10 S = ${WORKDIR}/tetex-src-${PV}
11
12 inherit autotools
13
14 PARALLEL_MAKE = ""
15
16 export BUILDCC = "${BUILD_CC}"
17 export BUILDCFLAGS = "${BUILD_CFLAGS}"
18 export BUILDLDFLAGS = "${BUILD_LDFLAGS}"
19 export BUILDCCLD = "${BUILD_CC}"
20
21 EXTRA_OECONF = "--with-system-libgd \
22                 --with-system-ncurses \
23                 --with-ncurses-include=${STAGING_INCDIR} \
24                 --with-system-pnglib \
25                 --with-system-t1lib \
26                 --with-system-zlib \
27                 --without-dialog \
28                 --without-xdvik"
29
30 # NOTE:  In theory, teTeX has a good buildsystem, which automatically detects
31 #        whether we are cross-compiling and compiles the necessary host tools.
32 #        Unfortunately it doesn't work in our case and it looks easier to add
33 #        tetex-native for the time being. Cheers, Mickey.
34 do_configure () {
35         oe_runconf
36         ln -sf ${STAGING_BINDIR} ${S}/utils/texinfo/tools/info
37         ln -sf ${STAGING_BINDIR} ${S}/utils/texinfo/tools/makeinfo
38         cat >${S}/utils/texinfo/tools/Makefile <<EOF
39 install:
40         echo "done"
41 all:
42         echo "done"
43 EOF
44 }
45
46 # NOTE: This is really ugly. Unfortunately the teTeX people seem not to know about PREFIX...
47 do_install() {
48         install -d ${D}${bindir}
49         install -d ${D}${libdir}
50         install -d ${D}${datadir}/texmf
51         install -d ${D}${localstatedir}/lib/textmf
52
53         export bindir="${D}${bindir}" \
54         sbindir="${D}${sbindir}" \
55         libexecdir="${D}${libexecdir}" \
56         datadir="${D}${datadir}" \
57         sysconfdir="${D}${sysconfdir}" \
58         sharedstatedir="${D}${sharedstatedir}" \
59         localstatedir="${D}${localstatedir}" \
60         libdir="${D}${libdir}" \
61         includedir="${D}${includedir}" \
62         oldincludedir="${D}${oldincludedir}" \
63         infodir="${D}${infodir}" \
64         mandir="${D}${mandir}" \
65         texmf="${D}${datadir}/texmf" \
66         scriptdir="${D}${bindir}" \
67         web2cdir="${D}${datadir}" \
68         kpathsea="${D}${libdir}/libkpathsea.la" \
69         DESTDIR=""
70         MAKE="make -e" oe_runmake -e install
71 }
72
73 RRECOMMENDS_${PN} = "tetex-texmf-dvips tetex-texmf-texconfig tetex-texmf-fonts"
74 PACKAGES =+ "tetex-texmf-dvips tetex-texmf-texconfig tetex-texi2html"
75 FILES_${PN} += "${localstatedir} ${datadir}"
76 FILES_${PN}-doc += "${datadir}/texinfo ${datadir}/man ${datadir}/info"
77 FILES_tetex-texmf-dvips = "${datadir}/texmf/dvips"
78 FILES_tetex-texmf-texconfig = "${datadir}/texmf/texconfig"
79 FILES_tetex-texi2html = "${datadir}/texi2html"