]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/thttpd/thttpd_2.25b.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / thttpd / thttpd_2.25b.bb
1 DESCRIPTION = "A simple, small, portable, fast, and secure HTTP server."
2 LICENSE = "BSD"
3 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
4 HOMEPAGE = "http://www.acme.com/software/thttpd/"
5 PR="r5"
6
7 SRC_URI = "http://www.acme.com/software/thttpd/thttpd-2.25b.tar.gz \
8            file://install.patch;patch=1 \
9            file://acinclude.m4 \
10            file://init"
11 S = "${WORKDIR}/thttpd-${PV}"
12
13 INITSCRIPT_NAME = "thttpd"
14 INITSCRIPT_PARAMS = "defaults"
15
16 inherit autotools update-rc.d
17
18 EXTRA_OEMAKE += "'WEBDIR=${servicedir}/www'"
19 FILES_${PN}_append = " ${servicedir}"
20
21 do_configure () {
22         install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
23         autotools_do_configure
24 }
25
26 do_install_append () {
27         install -d "${D}${sysconfdir}/init.d"
28         cat ${WORKDIR}/init | sed -e 's,@@SRVDIR,${servicedir}/www,g' > ${WORKDIR}/thttpd
29         install -c -m 755 ${WORKDIR}/thttpd ${D}${sysconfdir}/init.d/thttpd
30 }
31