]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/tin/tin_1.7.3.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / tin / tin_1.7.3.bb
1 DESCRIPTION = "Tin is a powerful text mode news reader."
2 SECTION = "console/network"
3 DEPENDS = "ncurses"
4 PR = "r1"
5 LICENSE = "GPL"
6 SRC_URI = "ftp://ftp.tin.org/pub/news/clients/tin/unstable/tin-${PV}.tar.gz \
7            file://makecfg-buildcc.patch;patch=1 \
8            file://m4.patch;patch=1 \
9            file://configure.patch;patch=1"
10
11 inherit autotools 
12
13 EXTRA_OECONF = "--with-screen=ncurses"
14
15 do_compile () {
16         ${BUILD_CC} -DLINK_SIZE=2 -I${S}/include -c pcre/dftables.c
17         ${BUILD_CC} dftables.o -o pcre/dftables
18         oe_runmake build
19 }