]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/tinc/tinc_1.0.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / tinc / tinc_1.0.2.bb
1 SECTION = "console/network"
2 DESCRIPTION ="tinc is a Virtual Private Network (VPN) daemon"
3 HOMEPAGE = "http://www.tinc-vpn.org/"
4 LICENSE = "GPLv2"
5 MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
6 PR = "r1"
7
8 SRC_URI="http://www.tinc-vpn.org/packages/tinc-1.0.2.tar.gz \
9         file://mtu-vlan.diff;patch=1 \
10         file://public-key-fix.diff;patch=1 \
11         file://init"
12
13 DEPENDS = "openssl lzo zlib"
14 RRECOMMENDS = "kernel-module-tun"
15
16 inherit autotools
17
18 EXTRA_OECONF = "--disable-maintainer-mode --disable-tracing"
19
20 do_configure() {
21         oe_runconf
22 }
23
24 do_compile() {
25         oe_runmake
26 }
27
28 do_install() {
29         oe_runmake install DESTDIR=${D}
30         install -d ${D}${sysconfdir}/init.d
31         install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/tinc
32 }