]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/totem/totem_1.0.4.bb
libopie2: use common code to handle backlight settings on all iPAQs running Linux...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / totem / totem_1.0.4.bb
1 SECTION = "x11/multimedia"
2 # totem OE build file
3 # Copyright (C) 2004, Advanced Micro Devices, Inc.  All Rights Reserved
4 # Released under the MIT license (see packages/COPYING)
5
6 DESCRIPTION="A GTK2 based media player"
7 HOMEPAGE="http://www.gnome.org/projects/totem/"
8 LICENSE="GPL"
9 PR = "r1"
10
11 SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/totem/1.0/totem-${PV}.tar.gz \
12         file://include.patch;patch=1 \
13         file://omf.patch;patch=1 \
14         file://nonautilus.patch;patch=1 \
15         file://intl.patch;patch=1 \
16         file://cflags.patch;patch=1 \
17         file://gtkonly.patch;patch=1"
18
19 DEPENDS="gtk+ libglade gnome-vfs gconf libxine-x11 libxml2"
20
21 inherit autotools
22
23 EXTRA_OECONF="--disable-schemas-install --disable-nvtv --enable-gtk --disable-debug --disable-gstreamer --disable-mozilla --disable-lirc"
24
25 #SELECTED_OPTIMIZATION="-O0 -g"
26 LDFLAGS_append = " -Wl,--export-dynamic"
27
28 pkg_postinst_totem() {
29 #!/bin/sh
30 if [ -n "$D"  ]; then exit 1; fi; 
31 SOURCE=`gconftool-2 --get-default-source`
32 GCONF_CONFIG_SOURCE=$SOURCE gconftool-2 --makefile-install-rule \
33 /etc/gconf/schemas/totem.schemas > /dev/null
34 }