]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/twin/twin_0.4.6.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / twin / twin_0.4.6.bb
1 DESCRIPTION = "Twin is a text-mode windowing environment: it draws and manages text windows on a text-mode display, like X11 does for graphical windows. It has a built-in window manager and terminal emulator, and can be used as server for remote clients in the same style as X11. It can display on Linux console, on X11 and inside itself."
2 MAINTAINER = "Chris Lord <cwiiis@blueyonder.co.uk>"
3 SECTION = "console/utils"
4
5 DEPENDS = "coreutils-native"
6 LICENSE = "GPL LGPL"
7 SRC_URI = "http://linuz.sns.it/~max/twin/twin-0.4.6.tar.gz \
8            file://cross_compile.patch;patch=1"
9
10 EXTRA_OECONF = " --disable-tt-hw-x11 --disable-hw-x11 --disable-tt-hw-gtk"
11
12 inherit autotools
13
14 do_compile () {
15         oe_runmake 'HOSTCC=${BUILD_CC}'
16 }
17
18 do_stage () {
19         oe_soinstall libs/libTw/libTw.so.3.0.9 ${STAGING_LIBDIR}
20         install -d ${STAGING_INCDIR}/Tw
21         install -m 0644 include/Tw/*.h ${STAGING_INCDIR}/Tw/
22 }