]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/tximage/tximage_0.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / tximage / tximage_0.2.bb
1 DESCRIPTION = "Tx Image Viewer"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "GPL"
6 HOMEPAGE = "http://community.zaurus.com/projects/tximage/"
7 PR = "r1"
8
9 SRC_URI = "http://www.openzaurus.org/mirror/tximage-${PV}.tar.gz \
10            file://gcc3.patch;patch=1"
11
12 inherit palmtop
13
14 do_install() {
15         install -d ${D}${palmtopdir}/apps/Applications \
16                    ${D}${palmtopdir}/pics \
17                    ${D}${palmtopdir}/bin
18         install -D -m 755 tximage ${D}${palmtopdir}/bin/tximage
19         install -D -m 644 imageviewer.desktop ${D}${palmtopdir}/apps/Applications/tximage.desktop
20         cp -pPR tximage.png ${D}${palmtopdir}/pics/
21 }