]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/uae/e-uae_0.8.27.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / uae / e-uae_0.8.27.bb
1 DESCRIPTION = "Amiga Emulator based on SDL"
2 SECTION = "base"
3 PRIORITY = "optional"
4 DEPENDS = "libsdl-qpe"
5 LICENSE = "GPL"
6 PR = "r1"
7
8 SRC_URI = "http://rcdrummond.net/uae/e-uae-${PV}/e-uae-${PV}.tar.bz2 \
9            file://configure.patch;patch=1"
10 #           file://m4.patch;patch=1"
11
12 inherit autotools 
13
14 EXTRA_OECONF = "--with-hostcc=gcc --disable-ui --without-x \
15                 --without-gtk --enable-jit --disable-natmem \
16                 --with-zlib=${STAGING_LIBDIR}/.. \
17                 --with-sdl-exec-prefix=${STAGING_BINDIR}/.. \
18                 --with-sdl-prefix=${STAGING_LIBDIR}/.."
19
20 CFLAGS_append = " -DSTAT_STATFS2_BSIZE=1 "
21 CXXFLAGS_append = " -DSTAT_STATFS2_BSIZE=1 "
22 PARALLEL_MAKE = ""
23
24 do_configure_prepend () {
25         touch NEWS AUTHORS ChangeLog
26 }
27
28 do_install_append() {
29 # Packages NEVER, ever, ever, ever touch home directories directly.
30 # ever.
31 # Either update a global config in /etc, install it into /etc/skel/ for
32 # new users homedirs, rely on the user installing it to put it in place,
33 # or dont install it at all.  --CL
34 #       install -d ${D}/home/root
35 #       install ${FILESDIR}/uaerc ${D}/home/root/.uaerc
36 }