]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/uclibc/uclibc_0.9.27.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / uclibc / uclibc_0.9.27.bb
1 DEFAULT_PREFERENCE = "1"
2 PR = "r7"
3
4 include uclibc.inc
5
6 # This patch removes the typedef of __kernel_key_t from
7 # include/bits/ipc.h.  Because this removes a typedef some
8 # packages which relied on it (erroneously - it is defined
9 # in include/linux/posix_types.h and is internal) may stop
10 # building.  The patch has only been verified on NSLU2 builds.
11 PATCH_ipc_h ?= ""
12 PATCH_ipc_h_nslu2 = "file://kernel-key-t-ipc.h.patch;patch=1"
13
14 SRC_URI += "http://www.uclibc.org/downloads/uClibc-${PV}.tar.bz2 \
15             file://dyn-ldconfig.patch;patch=1 \
16             file://nokernelheadercheck.patch;patch=1"
17 SRC_URI += " file://armeb-kernel-stat.h.patch;patch=1"
18 SRC_URI += "${PATCH_ipc_h}"
19 SRC_URI += " file://thumb-swi.patch;patch=1"
20 SRC_URI += " file://thumb-swp.patch;patch=1"
21 SRC_URI += " file://arm-thumb-defined.patch;patch=1"
22
23 # ARM thumb interworking - these changes fix various bugs in the
24 # uclibc implementation of thumb interwork support, but they are
25 # insufficient on their own - it is also necessary (at present)
26 # to *disable* the uClibc ARM specific string code (the assembler
27 # doesn't support interworking).  Since these patches do actually
28 # change the non-interwork case and make things incompatible with
29 # older (pre armv4t) ARMs they are condition on the thumb-interwork
30 # override (i.e. the *distro* has to add this to OVERRIDES).
31 ARM_THUMB_INTERWORK_PATCHES = ""
32 ARM_THUMB_INTERWORK_PATCHES_thumb-interwork = ""
33 ARM_THUMB_INTERWORK_PATCHES_thumb-interwork += " file://thumb-ldso-dlboot.patch;patch=1"
34 ARM_THUMB_INTERWORK_PATCHES_thumb-interwork += " file://thumb-interwork-asm.patch;patch=1"
35 # See the comments in the patch - this doesn't work.
36 #ARM_THUMB_INTERWORK_PATCHES_thumb-interwork += " file://thumb-static-main.patch;patch=1"
37 SRC_URI += "${ARM_THUMB_INTERWORK_PATCHES}"
38
39 S = "${WORKDIR}/uClibc-${PV}"