]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/uclibc/uclibc_0.9.28.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / uclibc / uclibc_0.9.28.bb
1 DEFAULT_PREFERENCE = "1"
2 PR = "r3"
3
4 include uclibc.inc
5
6 # This is the correct KERNEL_SOURCE location, if the uClibc
7 # fix_includes.sh script is run (see nokernelheader.patch below)
8 # this must be correct.
9 KERNEL_SOURCE = "${CROSS_DIR}/${TARGET_SYS}"
10
11 SRC_URI += "http://www.uclibc.org/downloads/uClibc-${PV}.tar.bz2"
12
13 S = "${WORKDIR}/uClibc-${PV}"
14
15 #*** PATCHES ***
16 #
17 # The nokernelheadercheck patch removes the check on the include
18 # files in ${KERNEL_SOURCE}, however this check seems to be
19 # functioning correct now so the patch is not included.  It may
20 # be necessary to add this for architectures which do not initially
21 # have a 'good' set of kernel header files in the cross directory.
22 #SRC_URI += "file://nokernelheadercheck.patch;patch=1"
23 #
24 # Thumb support
25 SRC_URI += " file://thumb-defined-arm-or-thumb.patch;patch=1"
26 #
27 # Thumb interworking support
28 SRC_URI += " file://thumb-mov-pc-bx.patch;patch=1"
29 SRC_URI += " file://thumb-swi-r7.patch;patch=1"
30 SRC_URI += " file://thumb-sysnum-h.patch;patch=1"
31 SRC_URI += " file://thumb-asm-swi.patch;patch=1"
32 SRC_URI += " file://thumb-call-via-rx.patch;patch=1"
33 #
34 # This is a core change and is controversial, maybe even wrong
35 # on some architectures
36 THUMB_INTERWORK_RESOLVE_PATCH = ""
37 THUMB_INTERWORK_RESOLVE_PATCH_thumb-interwork = " file://thumb-resolve.patch;patch=1"
38 SRC_URI += " ${THUMB_INTERWORK_RESOLVE_PATCH}"