]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/uclibc/uclibc_svn.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / uclibc / uclibc_svn.bb
1 # UCLIBC_BASE should be the latest released revision of uclibc (that way
2 # the config files will typically be correct!)  uclibc-cvs takes precedence
3 # over uclibc-${UCLIBC_BASE}, if a config file in uclibc-cvs is out of date 
4 # try removing it
5 #
6 # UCLIBC_BASE can be set in a distro file, but whether this works depends
7 # on whether the base patches apply to the selected (CVSDATE) svn release.
8 #
9 UCLIBC_BASE ?= "0.9.28"
10 PV = "${UCLIBC_BASE}+svn${CVSDATE}"
11 #DEFAULT_PREFERENCE is 0 (empty), releases have a preference of 1 so take
12 # precedence.
13
14 include uclibc.inc
15
16 FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/uclibc-cvs', '${FILE_DIRNAME}/uclibc-${UCLIBC_BASE}', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
17
18 # This is the correct KERNEL_SOURCE location, if the uClibc
19 # fix_includes.sh script is run (see nokernelheader.patch below)
20 # this must be correct.
21 KERNEL_SOURCE = "${CROSS_DIR}/${TARGET_SYS}"
22
23 SRC_URI += "svn://uclibc.org/trunk;module=uClibc"
24
25 S = "${WORKDIR}/uClibc"
26
27 #*** PATCHES ***
28 #
29 # The nokernelheadercheck patch removes the check on the include
30 # files in ${KERNEL_SOURCE}, however this check seems to be
31 # functioning correct now so the patch is not included.  It may
32 # be necessary to add this for architectures which do not initially
33 # have a 'good' set of kernel header files in the cross directory.
34 #UCLIBC_PATCHES += "file://nokernelheadercheck.patch;patch=1"
35 #
36 # Thumb support
37 UCLIBC_PATCHES += " file://thumb-defined-arm-or-thumb.patch;patch=1"
38 #
39 # Thumb interworking support
40 UCLIBC_PATCHES += " file://thumb-mov-pc-bx.patch;patch=1"
41 UCLIBC_PATCHES += " file://thumb-resolve.patch;patch=1"
42
43 # Set this for non-head patches (the above list should match the
44 # requirements of the SVN head).
45 UCLIBC_SVN_PATCHES ?= "${UCLIBC_PATCHES}"
46
47 SRC_URI += "${UCLIBC_SVN_PATCHES}"