]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/udev/udev_065.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / udev / udev_065.bb
1 SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
2            file://tmpfs.patch;patch=1 \
3            file://noasmlinkage.patch;patch=1 \
4            file://flags.patch;patch=1 \
5            file://tty-symlinks.patch;patch=1"
6
7 include udev.inc
8
9 PR = "r2"
10 UDEV_EXTRAS = "extras/scsi_id/ extras/volume_id/ extras/run_directory/"
11
12 #FIXME UDEV MIGRATION PLAN:
13 #FIXME      a) udevd is now a netlink daemon and needs to be started by the init script (ours is way too old)
14 #FIXME      b) sbin/hotplug should no longer be called by the kernel, i.e. echo "" >/proc/sys/kernel/hotplug
15 #FIXME done c) until d) happens, udev will emulate hotplugd behaviour (see do_install_append()
16 #FIXME      d) eventually hotplug should no longer be used at all, all agents shall be converted to udev rules
17
18 do_install_append() {
19         install -m 0755 extras/run_directory/udev_run_hotplugd ${D}${sbindir}/
20         echo RUN+="/sbin/udev_run_hotplugd" >>${D}${sysconfdir}/udev/rules.d/50-udev.rules
21 }