]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/udev/udev_084.bb
udev: apply patch courtesy of Stelios Koroneos to ship links.conf
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / udev / udev_084.bb
1 DESCRIPTION = "udev is a daemon which dynamically creates and removes device nodes from \
2 /dev/, handles hotplug events and loads drivers at boot time. It replaces \
3 the hotplug package and requires a kernel not older than 2.6.12."
4 RPROVIDES = "hotplug"
5
6 SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
7            file://noasmlinkage.patch;patch=1 \
8            file://flags.patch;patch=1 \
9            file://udevsynthesize.patch;patch=1 \
10            file://udevsynthesize.sh"
11
12 include udev.inc
13
14 INITSCRIPT_PARAMS = "start 03 S . start 55 0 6 ."
15
16 PR = "r4"
17
18 FILES_${PN} += "${base_libdir}"
19 UDEV_EXTRAS = "extras/firmware/ extras/scsi_id/ extras/volume_id/ extras/run_directory/"
20 EXTRA_OEMAKE += "libudevdir=/lib/udev"
21
22 do_install () {
23         install -d ${D}${usrsbindir} \
24                    ${D}${sbindir}
25         oe_runmake 'DESTDIR=${D}' INSTALL=install install
26         install -d ${D}${sysconfdir}/init.d
27         install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/udev
28
29         install -d ${D}${sysconfdir}/udev/rules.d/
30
31         install -m 0644 ${WORKDIR}/local.rules         ${D}${sysconfdir}/udev/rules.d/local.rules
32         install -m 0644 ${WORKDIR}/permissions.rules   ${D}${sysconfdir}/udev/rules.d/permissions.rules
33         install -m 0644 ${WORKDIR}/udev.rules          ${D}${sysconfdir}/udev/rules.d/udev.rules
34         install -m 0644 ${WORKDIR}/links.conf          ${D}${sysconfdir}/udev/links.conf
35         if [ "${UDEV_DEVFS_RULES}" = "1" ]; then
36                 install -m 0644 ${WORKDIR}/devfs-udev.rules ${D}${sysconfdir}/udev/rules.d/devfs-udev.rules
37         fi
38
39         install -d ${D}${sysconfdir}/udev/scripts/
40
41         install -m 0755 ${WORKDIR}/mount.sh ${D}${sysconfdir}/udev/scripts/mount.sh
42         install -m 0755 ${WORKDIR}/network.sh ${D}${sysconfdir}/udev/scripts
43
44         install -d ${D}${base_libdir}/udev/
45         install -m 0755 ${S}/udevsynthesize ${D}${base_libdir}/udev/udevsynthesize
46         install -m 0755 ${WORKDIR}/udevsynthesize.sh ${D}${sbindir}/udevsynthesize
47 }