]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/uicmoc/uicmoc3-native_3.3.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / uicmoc / uicmoc3-native_3.3.5.bb
1 DESCRIPTION = "User Interface Generator and Meta Object Compiler (moc) for Qt(E) 3.x"
2 SECTION = "devel"
3 PRIORITY = "optional"
4 LICENSE = "GPL QPL"
5 PR = "r1"
6
7 SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-free-${PV}.tar.bz2 \
8            file://no-examples.patch;patch=1"
9
10 S = "${WORKDIR}/qt-embedded-free-${PV}"
11
12 inherit native qmake-base qt3e
13
14 export QTDIR = "${S}"
15 export OE_QMAKE_LINK="${CXX}"
16 CXXFLAGS += " -DQWS"
17
18 QT_CONFIG_FLAGS = "-release -static -depths 8,16 -qt-zlib -no-nas-sound \
19                    -no-sm -no-libjpeg -no-libmng -no-gif -no-xshape -no-xinerama \
20                    -no-xcursor -no-xrandr -no-xrender -no-xft -no-tablet \
21                    -no-xkb -no-dlopen-opengl -no-freetype -no-thread \
22                    -no-nis -no-cups -prefix ${prefix} \
23                    -xplatform ${OE_QMAKE_PLATFORM} \
24                    -platform ${OE_QMAKE_PLATFORM}"
25
26 do_configure() {
27     oe_qmake_mkspecs
28     echo "yes" | ./configure ${QT_CONFIG_FLAGS}
29 }
30
31 do_compile() {
32     oe_runmake symlinks  || die "Can't symlink include files"
33     oe_runmake src-moc   || die "Building moc failed"
34     oe_runmake sub-tools || die "Building tools failed"
35 }
36
37 do_stage() {
38         install -d ${OE_QMAKE_INCDIR_QT}
39         install -d ${OE_QMAKE_LIBDIR_QT}
40
41         install -m 0755 bin/moc ${OE_QMAKE_MOC}
42         install -m 0755 bin/uic ${OE_QMAKE_UIC}
43         install -m 0655 lib/*.a ${OE_QMAKE_LIBDIR_QT}
44
45         for f in include/*.h
46         do
47                 install -m 0644 $f ${OE_QMAKE_INCDIR_QT}/
48         done
49 }