]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/upslug/upslug-native_1.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / upslug / upslug-native_1.0.bb
1 # This package builds the 'upslug' binary upload/flash tool
2 # for the NSLU2.  It is not useful for anything else.
3 PR = "r0"
4 DESCRIPTION = "NSLU2 binary upload tool"
5 HOMEPAGE = "http://www.nslu2-linux.org/wiki/Main/UpSlug"
6 MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
7 SECTION = "console/network"
8 PRIORITY = "optional"
9 LICENSE = "GPL-2"
10
11 SRC_TAG = "UPSLUG_${@'_'.join(bb.data.getVar('PV',d,1).split('.'))}"
12 SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/nslu;method=pserver;module=upslug;tag=${SRC_TAG}"
13 # For testing use this (tags and other changes take a day to
14 # propogate on sourceforge).  Change 'jbowler' to your login name!
15 #SRC_URI = "cvs://jbowler@cvs.sourceforge.net/cvsroot/nslu;method=ext;rsh=ssh;tag=${SRC_TAG};module=upslug"
16
17 inherit native
18
19 S = "${WORKDIR}/upslug"
20
21 # Dumb compile script
22 do_compile() {
23         oe_runmake "CC=${CC}" "CFLAGS=${CFLAGS}"
24 }
25
26 do_stage() {
27         oe_runmake "DESTDIR=${STAGING_BINDIR}" install
28 }
29
30 python () {
31         # Don't build upslug unless we're targeting an nslu2
32         mach = bb.data.getVar("MACHINE", d, 1)
33         if mach != 'nslu2':
34                 raise bb.parse.SkipPackage("upslug only builds for the Linksys NSLU2")
35 }