]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/upslug/upslug-native_cvs.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / upslug / upslug-native_cvs.bb
1 # This package builds the 'upslug' binary upload/flash tool
2 # for the NSLU2.  It is not useful for anything else.
3 PR = "r0"
4 DESCRIPTION = "NSLU2 binary upload tool"
5 HOMEPAGE = "http://www.nslu2-linux.org/wiki/Main/UpSlug"
6 MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
7 SECTION = "console/network"
8 PRIORITY = "optional"
9 LICENSE = "GPL-2"
10
11 # Use releases in preference
12 DEFAULT_PREFERENCE = "-1"
13
14 SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/nslu;method=pserver;module=upslug"
15
16 inherit native
17
18 S = "${WORKDIR}/upslug"
19
20 # Dumb compile script
21 do_compile() {
22         oe_runmake "CC=${CC}" "CFLAGS=${CFLAGS}"
23 }
24
25 do_stage() {
26         oe_runmake "DESTDIR=${STAGING_BINDIR}" install
27 }
28
29 python () {
30         # Don't build upslug unless we're targeting an nslu2
31         mach = bb.data.getVar("MACHINE", d, 1)
32         if mach != 'nslu2':
33                 raise bb.parse.SkipPackage("upslug only builds for the Linksys NSLU2")
34 }