]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/uqm/uqm_0.3.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / uqm / uqm_0.3.bb
1 DESCRIPTION = "Star Control 2 source port using SDL (see sc2.sourceforge.net)"
2 SECTION = "games"
3 PRIORITY = "optional"
4 DEPENDS = "virtual/libsdl libsdl-image libsdl-net libvorbis libogg zlib"
5 SECTION = "opie/games"
6 PRIORITY = "optional"
7 MAINTAINER = "Paul Eggleton <paule@handhelds.org>"
8 LICENSE = "GPL"
9
10 PR = "r1"
11
12 S = "${WORKDIR}/uqm-${PV}"
13
14 SRC_URI = "${SOURCEFORGE_MIRROR}/sc2/uqm-${PV}-source.tgz \
15            file://build-opts.sh \
16            file://build-oe.patch;patch=1;pnum=0"
17
18 do_configure() {
19         install ${WORKDIR}/build-opts.sh ${S}/
20         ./build-opts.sh ${STAGING_DIR} ${STAGING_BINDIR} ${STAGING_LIBDIR}
21 }
22
23 do_compile() {
24         export ARCH="${TARGET_ARCH}"
25         export CC="${CC}"
26         export STAGING_INCDIR="${STAGING_INCDIR}"
27         export STAGING_LIBDIR="${STAGING_LIBDIR}"
28         ./build.sh uqm
29 }
30
31 do_install() {
32         install -d ${D}${bindir}
33         install -m 0755 uqm ${D}${bindir}
34 }