]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/vera-fonts/ttf-bitstream-vera_1.10.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / vera-fonts / ttf-bitstream-vera_1.10.bb
1 DESCRIPTION = "The Bitstream Vera fonts - TTF Edition"
2 SECTION = "x11/fonts"
3 PRIORITY = "optional"
4 LICENSE = "Bitstream Vera"
5 PACKAGE_ARCH = "all"
6 PR = "r3"
7 RDEPENDS = "libfontconfig-utils"
8
9 SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ttf-bitstream-vera/1.10/ttf-bitstream-vera-${PV}.tar.bz2" 
10
11 do_install () { 
12         install -d ${D}${prefix}/share/fonts/ttf/ 
13         for i in *.ttf; do 
14                 install -m 644 $i ${D}${prefix}/share/fonts/ttf/${i} 
15         done 
16
17         # fontconfig ships this too.  not sure what to do about it.
18         #install -d ${D}${sysconfdir}/fonts 
19         #install -m 644 local.conf ${D}${sysconfdir}/fonts/local.conf 
20
21
22         install -d ${D}${prefix}/share/doc/${PN}/ 
23         for i in *.TXT; do 
24                 install -m 644 $i ${D}${prefix}/share/doc/${PN}/$i 
25         done 
26
27
28 pkg_postinst () {
29 #!/bin/sh
30 fc-cache
31 }
32
33
34 FILES_${PN} = "/etc ${datadir}/fonts"