]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/vim/vim_6.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / vim / vim_6.2.bb
1 DEPENDS = "ncurses"
2 DESCRIPTION = "Vim is an almost fully-compatible \
3 version of the Unix editor Vi."
4 SECTION = "console/utils"
5
6 LICENSE = "vim"
7
8 SRC_URI = "ftp://ftp.vim.org/pub/vim/unix/vim-${PV}.tar.bz2 \
9            file://configure.patch;patch=1"
10 S = "${WORKDIR}/vim62/src"
11
12 inherit autotools
13
14 EXTRA_OECONF = "--enable-gui=none --disable-gtktest \
15                 --disable-xim --with-features=normal \
16                 --disable-gpm --without-x --disable-netbeans \
17                 --with-tlib=ncurses"
18
19 do_configure () {
20         rm -f auto/*
21         touch auto/config.mk
22         aclocal
23         autoconf
24         oe_runconf
25         touch auto/configure
26         touch auto/config.mk auto/config.h
27 }
28
29 #FILES_${PN}-doc=${datadir}/vim/vim62/doc ${mandir} ${infodir}