]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/visiscript/visiscript_0.3.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / visiscript / visiscript_0.3.2.bb
1 DESCRIPTION = "VisiScript is a simple graphical frontend for \
2 scripting languages like minscript, Python,Ruby, Perl or others. \
3 VisiScript runs on the Qtopia desktop environment of the Zaurus."
4 SECTION = "opie/applications"
5 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
6 DEPENDS = "qscintilla"
7 LICENSE = "GPL"
8 APPNAME = "visiscript"
9 APPTYPE = "binary"
10 APPDESKTOP = "${S}"
11
12 SRC_URI = "http://www.mneuroth.de/privat/zaurus/visiscript_src_${PV}.tar.gz \
13            file://qptrlist.h file://qcleanuphandler.h"
14 S = "${WORKDIR}/visiscript-${PV}"
15
16 inherit opie
17
18 QMAKE_PROFILES = "zvisiscript.pro"
19
20 EXTRA_QMAKEVARS_POST = "CONFIG-=thread LIBS-=../qscintilla-1.60-gpl-1.3/qt/lib/libqscintilla_arm.a LIBS+=-lqscintilla"
21 export OE_QMAKE_LINK="${CXX}"
22
23 do_compile_prepend() {
24         install -m 0644 ${WORKDIR}/*.h ${S}
25 }
26
27 do_install() {
28         install -d ${D}${palmtopdir}/pics/
29         install -m 0644 Visiscript.png ${D}${palmtopdir}/pics
30 }
31
32 #FIXME: package help and translation