]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/vtun/vtun_2.6.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / vtun / vtun_2.6.bb
1 DESCRIPTION = "Virtual Tunnels over TCP/IP networks with traffic shaping, compression and encryption."
2 HOMEPAGE = "http://vtun.sourceforge.net/"
3 MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
4 SECTION = "console/network"
5 PRIORITY = "optional"
6 LICENSE = "GPL"
7 DEPENDS = "zlib lzo"
8 PR = "r1"
9
10 SRC_URI = "${SOURCEFORGE_MIRROR}/vtun/vtun-${PV}.tar.gz \
11         file://init \
12         file://makefile.in-ldflags.patch;patch=1;pnum=0"
13
14 S = "${WORKDIR}/vtun"
15
16 inherit autotools
17
18 do_configure() {
19         export BLOWFISH_HDR_DIR=${STAGING_INCDIR}/openssl
20         oe_runconf --with-lzo-headers=${STAGING_INCDIR} --with-ssl-headers=${STAGING_INCDIR}/openssl
21 }
22
23 do_install() {
24         oe_runmake INSTALL_OWNER="" DESTDIR=${D} install
25         install -d ${D}${sysconfdir}/init.d/
26         install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/vtund
27         install ${S}/scripts/vtund-start.conf ${D}${sysconfdir}
28 }
29
30 CONFFILES_${PN}_nylon = "${sysconfdir}/vtund-start.conf ${sysconfdir}/vtund.conf"