]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/w3cam/w3cam_0.7.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / w3cam / w3cam_0.7.2.bb
1 DESCRIPTION = "a small and fast cgi program to retrieve images from a V4L device."
2 SECTION = "console/network"
3 PRIORITY = "optional"
4 MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
5 DEPENDS="jpeg"
6 LICENSE = "GPLV2"
7 PR = "r0"
8
9 SRC_URI = "http://mpx.freeshell.net/w3cam-0.7.2.tar.gz \
10            file://staticpaths.patch;patch=1"
11
12 S = "${WORKDIR}/w3cam-0.7.2/"
13
14 inherit autotools
15
16 LDFLAGS += "-L${STAGING_LIBDIR}"
17 CFLAGS += "-L${STAGING_LIBDIR} -I${STAGING_INCDIR}"
18
19 EXTRA_OECONF = "--without-x --without-ttf-inc"
20
21 do_install() {
22         install -d ${D}${sbindir}
23         install -d ${D}${bindir}
24         install -d ${D}${mandir}/man1
25         install -d ${D}usr/cgi-bin
26         install -m 0755 ${S}w3camd/w3camd ${D}${sbindir}/w3camd
27         install -m 0755 ${S}w3cam.cgi ${D}usr/cgi-bin/w3camd.cgi
28         install -m 0755 ${S}vidcat ${D}${bindir}/vidcat
29         install -m 0644 ${S}vidcat.1 ${D}${mandir}/man1/vidcat.1
30 }
31