]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/x11/x11_6.2.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / x11 / x11_6.2.1.bb
1 SECTION = "x11/libs"
2 LICENSE = "XFree86"
3 PRIORITY = "optional"
4 MAINTAINER = "Greg Gilbert <greg@treke.net>"
5 DEPENDS = "xproto xextensions xau xtrans xdmcp"
6 DESCRIPTION = "Base X libs."
7 FILES_${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB"
8 FILES_${PN}-locale += "${datadir}/X11/locale"
9 PROVIDES = "x11"
10 PR = "r3"
11
12 SRC_URI = "${XLIBS_MIRROR}/libX11-${PV}.tar.bz2 \
13            file://errordb-keysymdb-path-fix.patch;patch=1 \
14            file://autofoo.patch;patch=1"
15 S = "${WORKDIR}/libX11-${PV}"
16
17 inherit autotools pkgconfig 
18
19 do_compile() {
20         (
21                 unset CC LD CXX CCLD
22 #               unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
23                 oe_runmake -C src/util 'CFLAGS= -D_GNU_SOURCE' 'LDFLAGS=' 'CXXFLAGS=' 'CPPFLAGS=' makekeys
24         )
25         oe_runmake
26 }
27
28 do_stage() {
29         install -c -m 644 include/X11/XKBlib.h ${STAGING_INCDIR}/X11/XKBlib.h
30         install -c -m 644 include/X11/Xcms.h ${STAGING_INCDIR}/X11/Xcms.h
31         install -c -m 644 include/X11/Xlib.h ${STAGING_INCDIR}/X11/Xlib.h
32         install -c -m 644 include/X11/Xlibint.h ${STAGING_INCDIR}/X11/Xlibint.h
33         install -c -m 644 include/X11/Xlocale.h ${STAGING_INCDIR}/X11/Xlocale.h
34         install -c -m 644 include/X11/Xresource.h ${STAGING_INCDIR}/X11/Xresource.h
35         install -c -m 644 include/X11/Xutil.h ${STAGING_INCDIR}/X11/Xutil.h
36         install -c -m 644 include/X11/cursorfont.h ${STAGING_INCDIR}/X11/cursorfont.h
37         install -c -m 644 include/X11/region.h ${STAGING_INCDIR}/X11/region.h
38
39         oe_libinstall -a -so -C src libX11 ${STAGING_LIBDIR}
40 }