]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/x11/x11_cvs.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / x11 / x11_cvs.bb
1 PV = "6.2.1cvs${CVSDATE}"
2 LICENSE = "XFree86"
3 PR = "r5"
4 SECTION = "x11/libs"
5 PRIORITY = "optional"
6 MAINTAINER = "Greg Gilbert <greg@treke.net>"
7 DEPENDS = "xproto xextensions xau xtrans xdmcp"
8 DESCRIPTION = "Base X libs."
9 FILES_${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB"
10 FILES_${PN}-locale += "${datadir}/X11/locale"
11 PROVIDES = "x11"
12
13 SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xlibs;module=X11 \
14            file://errordb-keysymdb-path-fix.patch;patch=1"
15 S = "${WORKDIR}/X11"
16
17 inherit autotools pkgconfig 
18
19 do_compile() {
20         (
21                 unset CC LD CXX CCLD
22 #               unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
23                 oe_runmake -C src/util 'CFLAGS=' 'LDFLAGS=' 'CXXFLAGS=' 'CPPFLAGS=' makekeys
24         )
25         rm -f ${STAGING_INCDIR}/X11/Xlib.h
26         oe_runmake
27 }
28
29 do_stage() {
30         install -c -m 644 include/X11/XKBlib.h ${STAGING_INCDIR}/X11/XKBlib.h
31         install -c -m 644 include/X11/Xcms.h ${STAGING_INCDIR}/X11/Xcms.h
32         install -c -m 644 include/X11/Xlib.h ${STAGING_INCDIR}/X11/Xlib.h
33         install -c -m 644 include/X11/Xlibint.h ${STAGING_INCDIR}/X11/Xlibint.h
34         install -c -m 644 include/X11/Xlocale.h ${STAGING_INCDIR}/X11/Xlocale.h
35         install -c -m 644 include/X11/Xresource.h ${STAGING_INCDIR}/X11/Xresource.h
36         install -c -m 644 include/X11/Xutil.h ${STAGING_INCDIR}/X11/Xutil.h
37         install -c -m 644 include/X11/cursorfont.h ${STAGING_INCDIR}/X11/cursorfont.h
38         install -c -m 644 include/X11/region.h ${STAGING_INCDIR}/X11/region.h
39
40         oe_libinstall -a -so -C src libX11 ${STAGING_LIBDIR}
41 }