]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/xaw/xaw_7.0.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / xaw / xaw_7.0.2.bb
1 SECTION = "x11/libs"
2 LICENSE = "MIT"
3 PRIORITY = "optional"
4 MAINTAINER = "Phil Blundell <pb@handhelds.org>"
5 DEPENDS = "xproto x11 xt xmu xpm"
6 DESCRIPTION = "X Athena Widgets library"
7
8 SRC_URI = "${XLIBS_MIRROR}/libXaw-${PV}.tar.bz2 \
9            file://auxdir.patch;patch=1"
10
11 S = "${WORKDIR}/libXaw-${PV}"
12
13 inherit autotools pkgconfig 
14
15 # FIXME: libXaw needs a full x11, not diet
16 BROKEN = "1"
17
18 do_stage () {
19         oe_runmake install DESTDIR="" mandir=${STAGING_DATADIR}/man bindir=${STAGING_BINDIR} includedir=${STAGING_INCDIR} libdir=${STAGING_LIBDIR} prefix=${STAGING_DIR}
20 }