]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/xev/xev_cvs.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / xev / xev_cvs.bb
1 PV = "0.0cvs${CVSDATE}"
2 DESCRIPTION = "X Event Viewer"
3 HOMEPAGE = "http://freedesktop.org/wiki/Software_2fxapps"
4 LICENSE = "MIT"
5 MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
6 SECTION = "x11/base"
7 DEPENDS = "x11 xau"
8 PR = "r1"
9
10 SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xapps;module=xev \
11            file://diet-x11.patch;patch=1"
12 S = "${WORKDIR}/xev"
13
14 do_compile() {
15         ${CC} -o xev xev.c -lX11 -lXau -I${STAGING_INCDIR} -L${STAGING_LIBDIR}
16 }
17
18 do_install() {
19         install -d ${D}${bindir}
20         install -m 755 ${PN} ${D}${bindir}
21 }