]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/xmame/xmame_0.86.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / xmame / xmame_0.86.bb
1 DESCRIPTION = "Multiple Arcade Machine Emulator based on SDL"
2 LICENSE = "xmame"
3 SECTION = "games"
4 PRIORITY = "optional"
5 DEPENDS = "expat virtual/libsdl libsdl-mixer"
6
7 SRC_URI = "http://x.mame.net/download/historic/${P}.tar.bz2 \
8           file://${FILESDIR}/crosscompile.patch;patch=1"
9
10 inherit flow-lossage
11
12 EXTRA_OEMAKE=
13
14 do_compile() {
15     oe_runmake TARGET=mame JOY_SDL=1 SOUND_SDL=1 DISPLAY_METHOD=SDL                                   \
16                CC="${CC}" CXX="${CXX}" CFLAGS="-I. -Isrc -Isrc/include -Isrc/unix ${CFLAGS}"          \
17                CXXFLAGS="${CXXFLAGS}" LD="${CC}" LDFLAGS="${LDFLAGS}"                                 \
18                RANLIB="${RANLIB}" MY_CPU="${TARGET_ARCH}" ARCH="${TARGET_OS}"                         \
19                GLLIBS="" STRIP="${STRIP}" AR="${AR}"
20 }
21
22 do_install() {
23         install -d ${D}${bindir}
24         install -m 0755 xmame.SDL ${D}${bindir}
25 }
26