]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/zaurus-updater/zaurus-updater.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / zaurus-updater / zaurus-updater.bb
1 DESCRIPTION = "Encrypted shellscript for the Zaurus ROM update"
2 DEPENDS = "encdec-updater-native"
3 LICENSE = "zaurus-updater"
4 PR = "r4"
5
6 SRC_URI = "file://updater.sh \
7            file://gnu-tar.gz"
8 S = "${WORKDIR}"
9
10 do_compile() {
11         encdec-updater -e updater.sh
12 }
13
14 do_deploy() {
15         install -d ${DEPLOY_DIR}/images/
16         install -m 0755 updater.sh ${DEPLOY_DIR}/images/updater.sh.${MACHINE}
17
18         case ${MACHINE} in
19                 spitz | borzoi )
20                         install -m 0755 gnu-tar ${DEPLOY_DIR}/images/gnu-tar
21                         ;;
22                 *)
23                         ;;
24         esac
25 }
26
27 addtask deploy before do_build after do_compile