]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/zeroconf/zeroconf_0.6.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / zeroconf / zeroconf_0.6.1.bb
1 DESCRIPTION = "IPv4 link-local address allocator"
2 HOMEPAGE = "http://www.progsoc.org/~wildfire/zeroconf/"
3 LICENSE = "GPL"
4 SECTION = "net"
5 PRIORITY = "optional"
6
7 PR = "r0"
8
9 SRC_URI = "http://www.progsoc.org/~wildfire/zeroconf/download/${PN}-${PV}.tar.gz \
10            file://debian-zeroconf.patch;patch=1 \
11            file://busybox.patch;patch=1 \
12            file://zeroconf-default"
13
14 do_install () {
15         install -d ${D}${sbindir}
16         install -d ${D}${sysconfdir}/network/if-up.d
17         install -d ${D}${sysconfdir}/default
18         install -c -m 755 ${S}/zeroconf ${D}${sbindir}/zeroconf
19         install -c -m 755 ${S}/zeroconf.sh ${D}${sysconfdir}/zeroconf
20         install -c -m 755 ${S}/debian-zeroconf ${D}${sysconfdir}/network/if-up.d/zeroconf
21         install -c ${WORKDIR}/zeroconf-default ${D}${sysconfdir}/default/zeroconf
22 }