]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/zroadmap/zroadmap_1.0.8.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / zroadmap / zroadmap_1.0.8.bb
1 DESCRIPTION = "RoadMap is a program that provides a car navigation for Linux and UNIX. \
2 It displays a map of the streets, tracks the position provided by a NMEA-compliant \
3 GPS receiver, identifies the street matching this GPS position and announces the name \
4 of the crossing street at the next intersection. A rudimentary trip feature allows \
5 RoadMap to display some basic navigation information (distance to the destination, \
6 direction, speed, etc..). Voice messages are generated that duplicate some of the screen information."
7 SECTION = "opie/applications"
8 PRIORITY = "optional"
9 AUTHOR = "Pascal Martin <pascal.martin@iname.com>"
10 HOMEPAGE = "http://roadmap.digitalomaha.net/maps.html"
11 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
12 LICENSE = "GPL"
13 PR = "r2"
14
15 SRC_URI = "http://roadmap.digitalomaha.net/roadmap/roadmap_1_0_8_src.tar.gz \
16            http://roadmap.digitalomaha.net/maps/usdir.rdm.tgz \
17            file://zroadgps.png"
18
19 S = "${WORKDIR}/roadmap-${PV}/src/qt"
20
21 inherit palmtop
22
23 EXTRA_OEMAKE = 'DESKTOP=QPE MOC=${OE_QMAKE_MOC} UIC=${OE_QMAKE_UIC} \
24                 GUILDFLAGS="-lz -lpng -ljpeg -lts -lqte -lqpe -Wl,-rpath-link,${STAGING_LIBDIR} -L${STAGING_LIBDIR} -L${QTDIR}/lib"'
25 PARALLEL_MAKE = ""
26
27 do_configure() {
28         rm -rf moc*
29 }
30
31 do_install() {
32         install -d ${D}${palmtopdir}/bin
33         install -d ${D}${palmtopdir}/apps/Applications
34         install -d ${D}${palmtopdir}/pics
35         install -m 0755 qtroadmap ${D}${palmtopdir}/bin/roadmap
36         install -m 0755 qtroadgps ${D}${palmtopdir}/bin/roadgps
37         install -m 0644 ../roadmap.png ${D}${palmtopdir}/pics/zroadmap.png
38         install -m 0644 ${WORKDIR}/zroadgps.png ${D}${palmtopdir}/pics/zroadgps.png
39         install -m 0644 ipkg/*.desktop ${D}${palmtopdir}/apps/
40         install -d ${D}${palmtopdir}/share/roadmap/
41         install -m 0644 ../sprites ../schema ../preferences ${D}${palmtopdir}/share/roadmap/
42         install -m 0644 ${WORKDIR}/usdir.rdm ${D}${palmtopdir}/share/roadmap/
43 }