]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/zuc/zuc_1.1.2ern.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / zuc / zuc_1.1.2ern.bb
1 DESCRIPTION = "A Unit Conversion Tool"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "GPL"
6 APPTYPE = "binary"
7 APPNAME = "zuc"
8 APPDESKTOP = "${S}"
9 PR = "r3"
10
11 SRC_URI = "http://www.linux-solutions.at/projects/zaurus/source/zuc_V${PV}.tar.gz \
12            http://nick.kreucher.net/zuc/zuc_units"
13 S = "${WORKDIR}/zuc_V${PV}"
14
15 inherit opie
16
17 export OE_QMAKE_LINK="${CXX}"
18
19 do_configure_append() {
20         echo "#define VERSION \""${PV}"\"" > version.h
21         echo "#define BUILDTIME \""`date +%Y%m%d%H%M`"\"" >> version.h
22 }
23
24 do_install() {
25         install -d ${D}${palmtopdir}/pics/
26         install -m 0644 *.png ${D}${palmtopdir}/pics/
27         install -d ${D}${palmtopdir}/etc/
28         install -m 0644 ${WORKDIR}/zuc_units ${D}${palmtopdir}/etc/
29 }