]> pilppa.org Git - familiar-h63xx-build.git/blobdiff - org.handhelds.familiar/packages/dbus/dbus-native_1.0.1.bb
dbus-1.0.1: big update due to changes in DBUS API. Affected packages are: bluez-libs...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / dbus / dbus-native_1.0.1.bb
diff --git a/org.handhelds.familiar/packages/dbus/dbus-native_1.0.1.bb b/org.handhelds.familiar/packages/dbus/dbus-native_1.0.1.bb
new file mode 100644 (file)
index 0000000..a897ae5
--- /dev/null
@@ -0,0 +1,31 @@
+DESCRIPTION = "message bus system for applications to talk to one another"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "GPL"
+SECTION = "base"
+
+PR = "r0"
+
+DEPENDS = "glib-2.0-native libxml2-native expat-native"
+
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-1.0.1"
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+          file://cross.patch;patch=1 \
+          "
+
+inherit autotools pkgconfig gettext native
+
+S = "${WORKDIR}/dbus-${PV}"
+
+EXTRA_OECONF = "--disable-qt  --disable-qt3 --disable-gtk --disable-tests \
+               --disable-checks --disable-xml-docs --disable-doxygen-docs \
+               --with-xml=expat --without-x"
+
+do_stage () {
+       oe_runmake install
+       autotools_stage_all
+
+       # for dbus-glib-native introspection generation
+       install -d ${STAGING_DATADIR}/dbus
+       install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
+}