]> pilppa.org Git - familiar-h63xx-build.git/blobdiff - org.handhelds.familiar/packages/fastjar/fastjar-native_0.92+gcc3.4.4.bb
Add support for building java apps and libraries
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / fastjar / fastjar-native_0.92+gcc3.4.4.bb
diff --git a/org.handhelds.familiar/packages/fastjar/fastjar-native_0.92+gcc3.4.4.bb b/org.handhelds.familiar/packages/fastjar/fastjar-native_0.92+gcc3.4.4.bb
new file mode 100644 (file)
index 0000000..7f584b6
--- /dev/null
@@ -0,0 +1,36 @@
+# fastjar-native OE build file
+# Copyright (C) 2006, Rene Wagner. All Rights Reserved
+# Released under the MIT license (see org.handhelds.familiar/COPYING.MIT)
+
+DESCRIPTION = "jar replacement written in C."
+HOMEPAGE = "http://sourceforge.net/projects/fastjar/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "GPL"
+MAINTAINER = "Rene Wagner <rw@handhelds.org>"
+
+DEPENDS = "zlib"
+
+GCC_VER = "${@bb.data.getVar('PV',d,1).split('gcc')[1]}"
+SRC_URI = "${GNU_MIRROR}/gcc/gcc-${GCC_VER}/gcc-${GCC_VER}.tar.bz2"
+
+S = "${WORKDIR}/gcc-${GCC_VER}"
+
+inherit autotools native
+
+EXTRA_OECONF = "--with-system-zlib --with-fastjar"
+
+do_configure () {
+       gnu-configize || die "failure running gnu-configize"
+       oe_runconf
+}
+
+do_compile() {
+       oe_runmake maybe-all-fastjar
+}
+
+do_stage() {
+       install -d ${STAGING_BINDIR}
+       install -m 755 fastjar/jar ${STAGING_BINDIR}/fastjar
+       install -m 755 fastjar/grepjar ${STAGING_BINDIR}
+}