]> pilppa.org Git - familiar-h63xx-build.git/blobdiff - org.handhelds.familiar/packages/libfakekey/libfakekey_0.1.bb
matchbox-keyboard, libfakekey: use 0.1 releases and add smallscreen patch.
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libfakekey / libfakekey_0.1.bb
diff --git a/org.handhelds.familiar/packages/libfakekey/libfakekey_0.1.bb b/org.handhelds.familiar/packages/libfakekey/libfakekey_0.1.bb
new file mode 100644 (file)
index 0000000..6883d12
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "library for converting characters to X key-presses"
+LICENSE = "GPL"
+DEPENDS = "xtst"
+SECTION = "x11/wm"
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/${@'.'.join(bb.data.getVar('PV', d, 1).split('.')[:2])}/${PN}-${PV}.tar.bz2"
+
+inherit autotools pkgconfig gettext
+
+FILES_${PN} = "${libdir} \
+              ${datadir}/applications \
+              ${datadir}/pixmaps"
+
+do_stage () {
+       install -d ${STAGING_INCDIR}/fakekey    
+       install -m 0644 ${S}/fakekey/fakekey.h ${STAGING_INCDIR}/fakekey
+       oe_libinstall -so -C src libfakekey ${STAGING_LIBDIR}           
+}
+