]> pilppa.org Git - familiar-h63xx-build.git/blobdiff - org.handhelds.familiar/packages/linux/LAB-kernel_cvs.bb
LAB, kernel.bbclass: cleanup
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / LAB-kernel_cvs.bb
index d83e5b4fe5c2974e490209ea079ee1f2e9396cda..2fb1b79d4769984e83f59e406a0b89d44fe06432 100644 (file)
@@ -1,12 +1,8 @@
 SECTION = "kernel"
-DESCRIPTION = "Liux As Bootloader kernelm"
-MAINTAINER = "Koen Kooi <koen@linuxtogo.org>"
+DESCRIPTION = "Linux As Bootloader kernel"
 LICENSE = "GPL"
 PV = "${K_MAJOR}.${K_MINOR}.${K_MICRO}-hh${HHV}+cvs${CVSDATE}"
 
-#!BIG FAT WARNING:
-#build this *before* building your real kernel, otherwise external modules will pickup the wrong headers
-
 DEFAULT_PREFERENCE = "-1"
 
 COMPATIBLE_HOST = "arm.*-linux"
@@ -23,8 +19,7 @@ S = "${WORKDIR}/kernel26"
 
 inherit kernel
 
-FILES_kernel-image_h2200 = ""
-ALLOW_EMPTY_kernel-image_h2200 = 1
+KERNEL_NO_MODULES = "1"
 
 K_MAJOR = "2"
 K_MINOR = "6"
@@ -46,6 +41,14 @@ do_configure() {
         yes '' | oe_runmake oldconfig
 }
 
+do_stage() {
+       :
+}
+
+python do_package() {
+       return
+}
+
 do_deploy() {
         install -d ${DEPLOY_DIR}/images
         install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/LAB-image-${MACHINE}