]> pilppa.org Git - familiar-h63xx-build.git/blobdiff - org.handhelds.familiar/packages/meta/gpe-image.bb
familiar: rework feed handling. add config files for v0.8.4(-rc*).
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / meta / gpe-image.bb
index 3767611af300d37a1c8f5451d811b985f6403c6a..7d37c4f4fc555d8eacbce1ce5049ba8663bba511 100644 (file)
@@ -1,7 +1,15 @@
 FEED_URIS_append_openzaurus = " x11##http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/x11 "
 FEED_URIS_append_opensimpad = " x11##http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/x11 \
                                 gpe##http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/gpe"
-FEED_URIS_append_familiar   = " x11##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/x11"
+
+DISTRO_FEEDS_append_familiar () {
+
+# x11 - additional packages specific to the x11 graphical environment
+src/gz x11 ${DISTRO_FEED_PREFIX}/x11
+src/gz x11-${MACHINE} ${DISTRO_FEED_PREFIX}/x11/machine/${MACHINE}
+}
+
+DISTRO_LOCALE_FEEDS_PREFIXES_append_familiar = " ${DISTRO_FEED_PREFIX}/x11"
 
 PR = "r21"
 
@@ -55,7 +63,6 @@ export IPKG_INSTALL = "task-bootstrap gpe-task-base \
                       ${XSERVER} \
                       ${GPE_EXTRA_INSTALL}"
 
-IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp "
 ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
 
 inherit image_ipk