]> pilppa.org Git - lib1wire.git/blobdiff - src/Makefile.am
Api cleanups for device querying
[lib1wire.git] / src / Makefile.am
index 4ec0e883ffe3d4a6869ceaaa296aa089acaa7887..3ec5e9775ecf23650e30ba10f420a98ea407d2fa 100644 (file)
@@ -1,11 +1,12 @@
 lib_LTLIBRARIES = lib1wire.la
 lib1wire_la_SOURCES = \
        Data.cc Data.hh \
+       DataReader.cc DataReader.hh \
        Date.cc Date.hh \
+       Device.hh \
        DeviceConfig.cc DeviceConfig.hh \
-       DeviceData.cc DeviceData.hh \
-       DeviceTypeGeneric.hh \
-       DeviceTypeSensor.hh \
+       DeviceTypes.hh \
+       SensorDevice.hh \
        Factory.cc Factory.hh \
        Store.cc Store.hh \
        StoreDay.cc StoreDay.hh \
@@ -23,11 +24,12 @@ DISTCLEANFILES = Makefile.in
 lib1wireincludedir=$(includedir)/w1
 lib1wireinclude_HEADERS = \
        Data.hh \
+       DataReader.hh \
        Date.hh \
+       Device.hh \
        DeviceConfig.hh \
-       DeviceData.hh \
-       DeviceTypeGeneric.hh \
-       DeviceTypeSensor.hh \
+       DeviceTypes.hh \
+       SensorDevice.hh \
        Factory.hh \
        Store.hh \
        StoreDay.hh \