]> pilppa.org Git - lib1wire.git/blobdiff - src/Makefile.am
Moved files that were not w1 specific to libplp.
[lib1wire.git] / src / Makefile.am
index 3ec5e9775ecf23650e30ba10f420a98ea407d2fa..a0712d517a66649bcb8b8cdb536784e93edb8659 100644 (file)
@@ -1,21 +1,12 @@
-lib_LTLIBRARIES = lib1wire.la
+lib_LTLIBRARIES = \
+       lib1wire.la
+
 lib1wire_la_SOURCES = \
-       Data.cc Data.hh \
-       DataReader.cc DataReader.hh \
-       Date.cc Date.hh \
-       Device.hh \
-       DeviceConfig.cc DeviceConfig.hh \
-       DeviceTypes.hh \
-       SensorDevice.hh \
        Factory.cc Factory.hh \
-       Store.cc Store.hh \
-       StoreDay.cc StoreDay.hh \
-       StoreCache.cc StoreCache.hh \
        W1CounterDevice.cc W1CounterDevice.hh \
        W1Device.cc W1Device.hh \
-       W1TemperatureSensor.cc W1TemperatureSensor.hh \
-       W1Util.cc W1Util.hh \
-       W1Configure.hh
+       W1TemperatureSensor.cc W1TemperatureSensor.hh
+
 lib1wire_la_LDFLAGS = $(SRC_LIBS) $(all_libraries) -version-info 1:0:0 -no-undefined
 AM_CPPFLAGS = $(SRC_CFLAGS)
 
@@ -23,18 +14,7 @@ DISTCLEANFILES = Makefile.in
 
 lib1wireincludedir=$(includedir)/w1
 lib1wireinclude_HEADERS = \
-       Data.hh \
-       DataReader.hh \
-       Date.hh \
-       Device.hh \
-       DeviceConfig.hh \
-       DeviceTypes.hh \
-       SensorDevice.hh \
        Factory.hh \
-       Store.hh \
-       StoreDay.hh \
-       StoreCache.hh \
        W1CounterDevice.hh \
        W1Device.hh \
-       W1TemperatureSensor.hh \
-       W1Util.hh
\ No newline at end of file
+       W1TemperatureSensor.hh
\ No newline at end of file