]> pilppa.org Git - lib1wire.git/blobdiff - src/Makefile.am
Support for querying the list devices having data stored.
[lib1wire.git] / src / Makefile.am
index 67a7a4b5df7eb6c6769785fc5fac7638c85b6a32..ec3ec8f3df385d4c4fb974cc08de8b2fff028302 100644 (file)
@@ -2,12 +2,11 @@ lib_LTLIBRARIES = lib1wire.la
 lib1wire_la_SOURCES = \
        Factory.cc Factory.hh \
        W1Device.cc W1Device.hh \
-       W1Scanner.cc W1Scanner.hh \
        W1Store.cc W1Store.hh \
        W1TemperatureSensor.cc W1TemperatureSensor.hh \
        W1CounterDevice.cc W1CounterDevice.hh \
        W1Util.cc W1Util.hh \
-       W1DataList.cc W1DataList.hh \
+       DeviceData.cc DeviceData.hh \
        DeviceConfig.cc DeviceConfig.hh \
        Data.cc Data.hh \
        Date.cc Date.hh \
@@ -19,9 +18,13 @@ DISTCLEANFILES = Makefile.in
 
 lib1wireincludedir=$(includedir)/w1
 lib1wireinclude_HEADERS = \
+       Data.hh \
+       Date.hh \
+       DeviceConfig.hh \
+       DeviceData.hh \
+       Factory.hh \
+       W1CounterDevice.hh \
        W1Device.hh \
-       W1Scanner.hh \
        W1Store.hh \
        W1TemperatureSensor.hh \
-       Date.hh \
-       W1CounterDevice.hh
\ No newline at end of file
+       W1Util.hh
\ No newline at end of file