]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/dillo/dillo2_0.6.6.bb
3416b015056f33eac295470c8f8c76aafc5ef8c8
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / dillo / dillo2_0.6.6.bb
1 SECTION = "x11/network"
2 DESCRIPTION = "Lightweight gtk+2 browser."
3 LICENSE = "GPL"
4 DEPENDS = "gtk+"
5 RDEPENDS = "gdk-pixbuf-loader-xpm"
6 SRC_URI="http://www.dillo.org/download/dillo-${PV}.tar.gz \
7          file://gtk2.patch;patch=1;pnum=1 \
8          file://fix_about_syntax.patch;patch=1;pnum=1 \
9          file://dillo.desktop \
10          file://dillo.png \
11          file://dillorc"
12
13 MAINTAINER = "Chris Lord <cwiiis@handhelds.org>"
14 PRIORITY = "optional"
15
16 S = "${WORKDIR}/dillo-${PV}/"
17
18 inherit autotools pkgconfig
19
20 do_install() {
21         install -d ${D}${bindir}
22         install -d ${D}${datadir}/applications
23         install -d ${D}${datadir}/pixmaps
24         install -d ${D}${sysconfdir}
25         install -m 0644 ${WORKDIR}/dillo.desktop ${D}${datadir}/applications/dillo.desktop
26         install -m 0644 ${WORKDIR}/dillo.png ${D}${datadir}/pixmaps/dillo.png
27         install -m 0755 ${S}/src/dillo ${D}${bindir}/dillo
28         install -m 0644 ${WORKDIR}/dillorc ${D}${sysconfdir}/dillorc
29 }