]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/dillo/dillo2_0.6.6.bb
dillo2: adjust default dillorc to be suitable for small screen devices. Closes #1757.
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / dillo / dillo2_0.6.6.bb
1 SECTION = "x11/network"
2 DESCRIPTION = "Lightweight gtk+2 browser."
3 LICENSE = "GPL"
4 PRIORITY = "optional"
5 PR = "r1"
6
7 DEPENDS = "gtk+"
8 RDEPENDS = "gdk-pixbuf-loader-xpm"
9
10 SRC_URI="http://www.dillo.org/download/dillo-${PV}.tar.gz \
11          file://gtk2.patch;patch=1;pnum=1 \
12          file://fix_about_syntax.patch;patch=1;pnum=1 \
13          file://dillo.desktop \
14          file://dillo.png \
15          file://dillorc"
16
17 S = "${WORKDIR}/dillo-${PV}/"
18
19 inherit autotools pkgconfig
20
21 do_install() {
22         install -d ${D}${bindir}
23         install -d ${D}${datadir}/applications
24         install -d ${D}${datadir}/pixmaps
25         install -d ${D}${sysconfdir}
26         install -m 0644 ${WORKDIR}/dillo.desktop ${D}${datadir}/applications/dillo.desktop
27         install -m 0644 ${WORKDIR}/dillo.png ${D}${datadir}/pixmaps/dillo.png
28         install -m 0755 ${S}/src/dillo ${D}${bindir}/dillo
29         install -m 0644 ${WORKDIR}/dillorc ${D}${sysconfdir}/dillorc
30 }