]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/hostap/hostap-modules_0.3.9.bb
hostap-modules: add version info to Pretec entry in hostap_cs.conf. based on an org...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / hostap / hostap-modules_0.3.9.bb
1 DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
2 SECTION = "kernel/modules"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "GPL"
6 PR = "r9"
7
8 SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
9            file://hostap_cs.conf \
10            file://Makefile.patch;patch=1 \
11            file://add_event.patch;patch=1 \
12            file://no-sandisk-connect-twice.patch;patch=1 \
13            file://hostap-utsname.patch;patch=1 \
14            file://hostap_cardid.patch;patch=1"
15 SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
16         file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
17 SRC_URI_append_h3900 = " file://ipaq_compat.patch;patch=1 "
18
19 S = "${WORKDIR}/hostap-driver-${PV}"
20
21 inherit module
22
23 # Hack Alert :D
24 ARCH_mipsel = "mips"
25 MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
26
27 NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep"
28
29 do_install() {
30         install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net \
31                    ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
32                    ${D}${sysconfdir}/pcmcia
33         for i in ${NET_MODULES}
34         do
35                 install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
36         done
37         install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
38         install -m 0644 driver/etc/hostap_cs.conf ${D}${sysconfdir}/pcmcia/hostap_cs.conf
39         cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
40 }
41
42 PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
43 FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
44 FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci${KERNEL_OBJECT_SUFFIX}"
45 FILES_hostap-modules = "/lib/modules/"
46 RDEPENDS_hostap-modules-cs = "hostap-modules"
47 RDEPENDS_hostap-modules-pci = "hostap-modules"