]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/hostap/hostap-modules_0.3.9.bb
external kernel modules: PARALLEL_INSTALL fixes
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / hostap / hostap-modules_0.3.9.bb
1 DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
2 SECTION = "kernel/modules"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 PR = "r10"
6
7 PARALLEL_INSTALL_REPLACE_VERSIONS = "2.4.19-rmk6-pxa1-hh37 2.4.19-rmk6-pxa1-hh41.1"
8
9 SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
10            file://hostap_cs.conf \
11            file://Makefile.patch;patch=1 \
12            file://add_event.patch;patch=1 \
13            file://no-sandisk-connect-twice.patch;patch=1 \
14            file://hostap-utsname.patch;patch=1 \
15            file://hostap_cardid.patch;patch=1"
16 SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
17         file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
18 SRC_URI_append_h3600 = " file://ipaq_compat.patch;patch=1 "
19 SRC_URI_append_h3900 = " file://ipaq_compat.patch;patch=1 "
20
21 S = "${WORKDIR}/hostap-driver-${PV}"
22
23 inherit module
24
25 # Hack Alert :D
26 ARCH_mipsel = "mips"
27 MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
28
29 NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep"
30
31 do_install() {
32         install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net \
33                    ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
34                    ${D}${sysconfdir}/pcmcia
35         for i in ${NET_MODULES}
36         do
37                 install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
38         done
39         install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
40         install -m 0644 driver/etc/hostap_cs.conf ${D}${sysconfdir}/pcmcia/hostap_cs.conf
41         cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
42 }
43
44 PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
45 FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
46 FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci${KERNEL_OBJECT_SUFFIX}"
47 FILES_hostap-modules = "/lib/modules/"
48 RDEPENDS_hostap-modules-cs = "hostap-modules"
49 RDEPENDS_hostap-modules-pci = "hostap-modules"