]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libfakekey/libfakekey_0.1.bb
matchbox-keyboard, libfakekey: use 0.1 releases and add smallscreen patch.
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libfakekey / libfakekey_0.1.bb
1 DESCRIPTION = "library for converting characters to X key-presses"
2 LICENSE = "GPL"
3 DEPENDS = "xtst"
4 SECTION = "x11/wm"
5
6 SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/${@'.'.join(bb.data.getVar('PV', d, 1).split('.')[:2])}/${PN}-${PV}.tar.bz2"
7
8 inherit autotools pkgconfig gettext
9
10 FILES_${PN} = "${libdir} \
11                ${datadir}/applications \
12                ${datadir}/pixmaps"
13
14 do_stage () {
15         install -d ${STAGING_INCDIR}/fakekey    
16         install -m 0644 ${S}/fakekey/fakekey.h ${STAGING_INCDIR}/fakekey
17         oe_libinstall -so -C src libfakekey ${STAGING_LIBDIR}           
18 }
19