]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/libgcrypt/libgcrypt_1.2.3.bb
libgcrypt: upgrade to 1.2.3
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / libgcrypt / libgcrypt_1.2.3.bb
1 DESCRIPTION = "A general purpose cryptographic library based on the code from GnuPG"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 LICENSE = "GPL LGPL FDL"
5 DEPENDS = "libgpg-error"
6
7 # move libgcrypt-config into -dev package
8 FILES_${PN} = "${libdir}/lib*.so.*"
9 FILES_${PN}-dev += "${bindir}"
10
11 SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-${PV}.tar.gz"
12
13 inherit autotools binconfig
14
15 EXTRA_OECONF = "--without-pth --disable-asm --with-capabilities"
16
17 do_stage() {
18         oe_libinstall -so -C src libgcrypt ${STAGING_LIBDIR}
19         oe_libinstall -so -C src libgcrypt-pthread ${STAGING_LIBDIR}
20         install -m 0755 src/libgcrypt-config ${STAGING_BINDIR}/
21
22         install -d ${STAGING_INCDIR}/
23         for X in gcrypt.h gcrypt-module.h
24         do
25                 install -m 0644 src/${X} ${STAGING_INCDIR}/${X}
26         done
27
28 }