]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/linux/handhelds-sa_2.4.19-rmk6-pxa1-hh42.bb
handhelds-sa: upgrade to -hh42 and adjust defconfig. part of a fix for #1752.
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / linux / handhelds-sa_2.4.19-rmk6-pxa1-hh42.bb
1 SECTION = "kernel"
2 DESCRIPTION = "handhelds.org Linux kernel for StrongArm processor based devices."
3 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
4 LICENSE = "GPL"
5 PR = "r0"
6 DEFAULT_PREFERENCE = "-1"
7
8 KERNEL_CCSUFFIX = "-3.3.4"
9 COMPATIBLE_HOST = "arm.*-linux"
10 COMPATIBLE_MACHINE = '(h3600|simpad)'
11
12 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-sa-${PV}"
13 SRC_URI = "${HANDHELDS_CVS};module=linux/kernel;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')} \
14            file://defconfig-${PACKAGE_ARCH} \
15            file://ipaq-hal.init"
16
17 S = "${WORKDIR}/kernel"
18
19 inherit kernel update-rc.d
20
21 K_MAJOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[0]}"
22 K_MINOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[1]}"
23 K_MICRO = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[2]}"
24 RMKV    = "${@bb.data.getVar('PV',d,1).split('-')[1].split('rmk')[-1]}"
25 PXAV    = "${@bb.data.getVar('PV',d,1).split('-')[2].split('pxa')[-1]}"
26 HHV     = "${@bb.data.getVar('PV',d,1).split('-')[3].split('hh')[-1]}"
27
28 KERNEL_PRIORITY = "${@'%d' % (int(bb.data.getVar('K_MAJOR',d,1)) * 100000000 + int(bb.data.getVar('K_MINOR',d,1)) * 1000000 + int(bb.data.getVar('K_MICRO',d,1)) * 10000 + int(bb.data.getVar('RMKV',d,1)) * 1000 + int(bb.data.getVar('PXAV',d,1)) * 100 + float(bb.data.getVar('HHV',d,1)))}"
29
30 module_conf_h3600_micro = "alias ipaq_hal_3600 h3600_micro"
31 module_conf_h3600_asic = "alias ipaq_hal_3800 h3600_asic"
32 module_conf_sa1100_ir = "alias irda0 sa1100_ir"
33 module_conf_pcmcia_core = "options pcmcia_core ignore_cis_vcc=1"
34 module_conf_ppp_async = "alias ppp0 ppp_async"
35 module_conf_orinoco_cs = "options orinoco_cs ignore_cis_vcc=1"
36 module_conf_hostap_cs = "options hostap_cs ignore_cis_vcc=1"
37 module_conf_spectrum_cs = "options spectrum_cs ignore_cis_vcc=1"
38
39 module_autoload_h3600_ts = "h3600_ts"
40 module_autoload_apm = "apm"
41 module_autoload_h3600-uda1341 = "h3600-uda1341"
42 module_autoload_af_packet = "af_packet"
43 module_autoload_ppp_async = "ppp_async"
44 module_autoload_usb-eth = "usb-eth"
45
46 FILES_kernel += "/etc/init.d/ipaq-hal"
47 INITSCRIPT_NAME = "ipaq-hal"
48 INITSCRIPT_PARAMS = "start 21 S ."
49
50 do_configure_prepend() {
51         install -m 0644 ${WORKDIR}/defconfig-${PACKAGE_ARCH} ${S}/.config
52 }
53
54 do_install_append() {
55         install -d ${D}${sysconfdir}/init.d
56         install ${WORKDIR}/ipaq-hal.init ${D}${sysconfdir}/init.d/ipaq-hal
57 }